Instalação do sistema

OJS versão 2.4.5.0

Agradecemos seu interesse em utilizar o Open Journal Systems, desenvolvido pelo Public Knowledge Project. Antes de continuar, leia o documento README_pt incluído com o pacote. Para maiores informações sobre o Public Knowledge Project e outros sistemas desenvolvidos, acesse o portal do PKP. Clique em portal do Ibict/MCT e em Portal do SEER para maiores informações sobre o envolvimento do Instituto Brasileiro de Informação em Ciência e Tecnologia com o sistema. Para reportar erros, sugestões ou dúvidas sobre o Open Journal Systems visite o PKP Support Forum, ou Sistema de Controle de erros Bugzilla do PKP. Embora os fóruns sejam a forma preferencial de contato, também pode-se entrar em contato com a Equipe do SEER por meio dos formulários disponíveis na seção Fale conosco no portal do SEER e para a Equipe do PKP (pkp.contact@gmail.com).

Atualização

Caso esteja atualizando uma versão 2.x anterior, clique aqui para continuar.

Requisitos Básicos

  • PHP >= 4.2.0 (incluindo PHP 5.x). Sua versão atual do PHP é 5.2.17
  • MySQL >= 4.1 or PostgreSQL >= 7.1 (incluindo PosgreSQL 8.x)
  • Apache >= 1.3.2x ou >= 2.0.4x ou Microsoft IIS 6
  • Sistema Operacional: Qualquer sistema operacional que suporte o software acima, incluindo Linux, BSD, Solaris, Mac OS X, Windows

A falta de recursos impossibilita testes completos em todas as possibilidades de configuração e versões de plataformas, não havendo garantia implícita de funcionamento ou de suporte. Solicita-se enviar comentários sobre problemas, sucessos, configurações de máquina, entre outros comentários e sugestões para os devidos fóruns de discussão

Alterações às configurações podem ser realizadas após a instalação, editando o documento config.inc.php na base do diretório do sistema, ou através da interface de administração via web do sistema.

Suporte a Servidores de Bases de Dados

O sistema foi testado apenas com MySQL e PostgreSQL, embora outras bases de dados que utilizem o ADOdb possam funcionar (parcial ou completamente). Notificações sobre compatibilidade e/ou correções para funcionamento em sistemas de bases de dados(DBMSs) alternativos devem ser encaminhados à equipe do PKP.

Antes de Instalar

  1. Os seguintes arquivos e diretórios (e seus conteúdos) devem ter permissão de escrita:
    • Permissão atual de config.inc.php (opcional): Sim
    • Permissão atual de public/: Sim
    • Permissão atual de cache/: Sim
    • Permissão atual de cache/t_cache/: Sim
    • Permissão atual de cache/t_compile/: Sim
    • Permissão atual de cache/_db/: Sim
  2. Um diretório para armazenar os arquivos de submissão deve ser criado e com permissão de escrita (veja mais abaixo Configuração de Arquivos).

Configurações de idioma (Localização)

Para suporte total ao Unicode (UTF-8), escolha UTF-8 para todas as configurações de caracteres. Note que o suporte requer o MySQL >= 4.1.1 ou PostgreSQL >= 7.1. Suporte total ao Unicode requer o PHP >= 4.3.0 compilado com suporte à bibliotecambstring (habilitada em instalações padrão de versões mais recentes do PHP). Problemas com conjuntos de caracteres podem ocorrer caso estes requisitos não sejam atendidos pelo servidor.

O servidor atualmente tem suporte a mbstring: Sim


O idioma padrão do sistema. Consulte a documentação caso deseje suporte a idiomas não listados.
















*
*
*
*
*
*
*
*
*

*
*
*
*
*
*
*
Escolha qualquer idioma adicional para incluir no sistema. Os idiomas estarão disponíveis a todas as revistas hospedadas. Idiomas adicionais também podem ser instalados a qualquer tempo através da interface de administração via Web.
* Traduções marcadas podem estar incompletas.

A codificação utilizada para dados enviados e recebidos pelos navegadores.

A codificação utilizada para dados enviados e recebidos pela base de dados. Deve ser o mesmo do Cliente. Note que esta opção é suportada somente em bases MySQL >= 4.1.1 ou PostgreSQL >= 7.1. Escolha "Não disponível" caso a base de dados não atenda aos requisitos.

Conjunto de caracteres para armazenamento de dados na base. Note que esta funcionalidade é suportada somente no MySQL >= 4.1.1 ou PostgreSQL >= 7.1. Escolha "Não disponível" caso o servidor de bases de dados não atenda aos requisitos.

Configurações de arquivos


Digite o caminho físico completo para um diretório existente no servidor onde serão armazenados os documentos submetidos. Este diretório não deve possuir acesso direto via Web. Verifique se o diretório existe e se possui permissões de escrita antes da instalação. Os caminhos no Windows devem utilizar a barra delimitadora para frente, ex.: "C:/myjournal/files".
 

Seu servidor permite envio de arquivos: Sim

Seu servidor permite atualmente envio de arquivos no tamanho máximo de: 64M

Configurações de Segurança


SHA1 é recomendado caso o sistema suporte (requer PHP >= 4.3.0).

Conta do administrador

Este usuário será o Administrador do Portal e terá acesso completo ao sistema. Contas adicionais podem ser criadas após a instalação.

A senha deve ter no mínimo 6 caracteres.

Configurações de bases de dados

O sistema exige acesso a uma base de dados SQL para armazenar seus dados. Verifique os requisitos do sistema para a lista de bases de dados suportadas. Nos campos a seguir, informe as configurações a serem utilizadas para conexão ao servidor de bases de dados.


Drivers de bases de dados relacionados entre chaves ([]) não tiveram suas extensões PHP reconhecidas pelo sistema, e portanto não devem funcionar.
Os drivers não suportados, listados acima, são exibidos apenas em caráter acadêmico e experimental, não devendo funcionar por padrão. Somente poderão ser utilizados pelo sistema os drivers que tiverem suas extensões PHP prévia e corretamente instaladas no servidor.

Deixe o nome do servidor em branco para conectar através de socket de domínio em vez de TCP/IP. Não é necessário para o MySQL, que automaticamente utiliza sockets caso "localhost" seja digitado, porém é obrigatório para outras bases como o PostgreSQL.
 
Para utilizar esta opção, o servidor de bases de dados deve permitir criação de bases remotamente e o nome de usuário e senha devem possuir as permissões necessárias para criação de bases e tabelas. Caso ocorra um erro durante a instalação, crie manualmente a base de dados no servidor e execute novamente o instalador desabilitando esta opção.

Configurações OAI


Um identificador único de registros de metadados indexados através do protocolo de Coleta de Metadados do Open Archives Initiative.